What do I need to do before I upgrade from the mydlink Lite app to the mydlink app ?

Please make sure you have an iOS or Android mobile device that supports the OS requirement as follow;

  • Android: ver. 4.3 or later versions
  • iOS: ver. 9 or later versions
Note: You can use the same mydlink account to log into the mydlink app.
Rank: 3