Escenario configuración VLAN en DGS‑1510 por GUI y CLI

Escenario:

DGS_1510_Escenario_configuracion_VLAN 
• Configuración VLANs

Paso 1 – Crear la vlan.

Añadir la vlan id y picar en Apply. (L2 Features/VLAN/802.1Q VLAN)
Comandos CLI:
vlan 10

D-Link

Paso 2 - Editar el nombre
     VLAN Name: corporativa

Picar en Edit y modifique el nombre de la VLAN en la columna VLAN Name, una vez modificado el nombre pique al final de la linea en Apply.

Comandos CLI:
vlan 10
name corporativa

D-Link
 
Comandos CLI:

vlan 20
name invitados
exit
vlan 30
name router
exit

D-Link
 
Paso 3 – Configuración de Puertos

Disponemos de 3 tipos de puertos. (L2 Features/VLAN/VLAN Interface)

• Hybrid
• Access
• Trunk

 Ejemplo de un puerto en modo Híbrido:

 -Una vlan untagged (Nativa)
-Múltiples vlan tagged
(VID 2 untagged, ID 1 y 3 Tagged)
Comandos CLI:

configure terminal
interface ethernet 1/0/1
switchport hybrid native vlan 2
switchport hybrid allowed vlan tagged 1-3
end

D-Link

Ejemplo:  Vlan2 en modo Access (untagged )

Comandos CLI:

interface ethernet 1/0/1
switchport mode access
switchport access vlan 2
acceptable-frame admit-all
end

D-Link

Ejemplo: puerto trunk puro.                         
Sólo deja pasar vlans tagged

Comandos CLI:

configure terminal
interface ethernet 1/0/1
switchport mode trunk
switchport trunk native vlan tag
acceptable-frame tagged-only
end

D-Link

Paso 3.1- VLAN Corporativa.
En puertos 5 a 16 de cada unidad, donde se conectarán usuarios usar modo Access.

D-Link

Comandos CLI:
configure terminal
interface range ethernet 1/0/5-1/0/16
switchport mode access
switchport access vlan 10
acceptable-frame admit-all
end

configure terminal
interface range ethernet 2/0/5-2/0/16
switchport mode access
switchport access vlan 10
acceptable-frame admit-all
end

Paso 3.2- VLAN de invitados.
En puertos 17 a 22 de cada unidad, donde se conectarán invitados usar modo Access.

D-Link 

Comandos CLI:
configure terminal
interface range ethernet 1/0/17-1/0/22
switchport mode access
switchport access vlan 20
acceptable-frame admit-all
end

configure terminal
interface range ethernet 2/0/17-2/0/22
switchport mode access
switchport access vlan 20
acceptable-frame admit-all
end

Paso 3.3- VLAN para router.

En el puerto 24, donde se conectará el router.

D-Link
 
Comandos CLI:

configure terminal
interface range ethernet 1/0/23-1/0/24
switchport mode access
switchport access vlan 30
acceptable-frame admit-all
end

configure terminal
interface range ethernet 2/0/23-2/0/24
switchport mode access
switchport access vlan 30
acceptable-frame admit-all
end

Paso 4 – Configuración de interfaces IP para cada VLAN.(L3 Features/IPv4 Interface)

Ingrese en Interfaz IPv4, indique el ID correspondiente a la Vlan en el recuadro “Interface VLAN” y pique en Apply, luego pique en Edit para configurar la IP de la interfaz y pique en Apply para confirmar la configuración.

Comandos CLI:
interface vlan 10
ip address 192.168.10.1 255.255.255.0
exit

D-Link

Comandos CLI:
interface vlan 20
ip address 192.168.20.1 255.255.255.0
exit

D-Link

Comandos CLI:
interface vlan 30
ip address 172.16.0.1 255.255.255.0
exit

D-Link

DGS_1510_Escenario_configuracion_VLAN


Paso 5 – Crear una ruta estatica.
Crearemos una ruta por defecto hacia el router que da la conexión a Internet por medio de la VLAN30.

D-Link 

Comandos CLI:
configure terminal
ip route 0.0.0.0 0.0.0.0 172.16.0.254 primary
end

Paso 6 – Crear ACLs para bloquear el acceso de la red de invitados a la red corporativa.
Ingrese en la opción ACL/ACL Access List, en ACL Type seleccione la opción ALL y pique en Add ACL para para crear una ACL de tipo Standard IP (básica)y así negar el acceso de la red 192.168.20.0/24 a 192.168.10.0/24
Recuerde que las reglas se ejecutan secuencialmente.

Comandos CLI:
ip access-list  bloqueo 1

D-Link


una vez creada la regla cerrar la ventana (Add ACL Access List)para editar la regla creada, pique en Edit, dentro de la access list añadir las dos reglas necesarias picando en Add Rule.

Comandos CLI:
interface range ethernet 1/0/5-1/0/16
ip access-group bloqueo in
exit

D-Link

Agregar la regla inversa.

D-Link

Comandos CLI:
ip access-list  bloqueo 1
1 deny 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
2 deny 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
exit

Paso 7 – Asignar las ACLs a los puertos implicados.

Ingrese en ACL/ACL Interface Access Group y asocie el nombre de la ACL creada al puerto que corresponda.

D-Link 

Comandos CLI:
interface range ethernet 1/0/5-1/0/16
ip access-group bloqueo in
exit



Rank: 1.5

Otros usuarios también consultaron:

  • ¿Cómo activar el control de tormentas en el DGS-1210? Ver respuesta
  • ¿Cómo activar Prevención de ARP Spoofing en el DGS-1210? Ver respuesta
  • ¿Cómo configurar Link Aggreation en mi DGS-1210 Series? Ver respuesta
  • ¿Cómo configurar VLAN estáticas en DGS-1210? Ver respuesta
  • ¿Cómo configurar Voice VLAN en mi DGS-1210? Ver respuesta
  • ¿Cómo proteger el switch DGS-1210 contra virus maliciosos o ataques de gusanos? Ver respuesta
  • DHCP Server Screening en el DGS-1210 Ver respuesta
  • ¿Cómo configurar SIM Single IP en el DGS-1500? Ver respuesta
  • ¿Cómo configurar Auto Surveillance VLAN en mi DGS-1210 Series? Ver respuesta