Why can’t I download and update to the mydlink app version 2.00 ?

The new mydlink app version 2.00 requires iOS10.0 or higher or Android 5.0 or higher. Please make sure your mobile devices support the minimum requirement for installing and using the new mydlink app.
Rank: 4.5